Improved advanced settings

A new version of the add-on is available on Github, version 0.5.1!

Version 0.5.1 is more stable, has better control over the advanced settings, adds debug logging and support Philips livingwhite bulbs.

Download the latest version from GitHub:

https://github.com/cees-elzinga/script.xbmc.hue.ambilight/

Should you run into any problems, please enable the “debug logging” from the advanced settings panel. It will log a bunch of information to your xbmc.log that will greatly help me to debug the issue at hand.

xbmc addon

Advertisements

14 thoughts on “Improved advanced settings

  1. Ron van de Ven

    Tried the newest version of the amblight plugin, although I’m currently only experimenting with theatre mode not the “ambilight”part of it. The plugin still causes problems with xbmc, when i try to quit xbmc it will cause xbmc to become unresponsive and increase the time for closing down xbmc significantly. I have a quite a few HUE bulb, i was wondering how the group function in your plugin works, how I assign specific bulbs to a group. Furthermore as an extra option request, some people want to combine theatre mode and ambilight. Dim certain bulbs when the movie start and have other bulbs express color during the movie or just switch on.

    Reply
    1. meethue Post author

      Thanks for using the add-on 🙂 I’m not sure how to fix the responsiveness on shutdown..

      > I have a quite a few HUE bulb, i was wondering how the group function in your plugin works, how I assign specific bulbs to a group

      You can’t use the add-on for creating groups. (Actually I don’t think it’s even officially supported to create your own groups at all). The FAQ has a little howto on how to manually create a group. See “Creating a custom group”

      > Furthermore as an extra option request, some people want to combine theatre mode and ambilight. Dim certain bulbs when the movie start and have other bulbs express color during the movie or just switch on

      This is already implemented, but it’s hidden in the advanced setting. It’s called “Ambilight: Dim a group of lights when playback starts”. See the FAQ on Github, section “I would like to use 1 lamp for ambilight, and turn 2 other lights off”

      Reply
  2. Kai

    Hi, just a new feedback!
    For me it works now good, colorchanging cold be faster but it is already great.
    One thing I found out, but could also be a problem of myself. If lights are off before starting a movie and I start movie and then stop it lights will be on. Is there a way to configure a remember of light state?

    Reply
    1. meethue Post author

      Hi Kai,

      When the add-on starts it checks the status of the lights. If a light is turned off , it shouldn’t be used. So if it pops on when you stop playback it’s a bug in the code…

      Are you using the latest version?

      Reply
      1. Kai

        Hi, I don’t resart the script. It’s permanent running on my RaspberryPi with XBMC.
        I only restart sometimes a month. I’m using newest version.
        Or do you mean with addon start start of the movie?

      2. Kai

        OK, don’t know why, but now it works.
        I think problem was in front of RaspberryPi! 😉

  3. Nick

    Hi and thanks for this nice addon !
    Unfortunately it’s not working on my XBMC 12.2 on Windows 8 32-Bit.
    I tried the “hue” and “ambilight” plugin which are installed and available in XBMC afterwards (after XBMC restart) but don’t seem to work. When choosing “Auto Detection” the script doesn’t seem to find the bridge or at least doesn’t give a positive feedback so I manually entered the IP. And although after having chosen the bulb(s) which shall be affected, nothing happens. Neither my bulb’s brightness changes (Hue plugin) when a movie was started nor it’s colors (Ambilight plugin).
    And: I tried to install the XBMC add-on “requests” plugin which is needed for “ambilight” but for this I don’t get a positive installation feedback and also cannot find it in the AddOn overview.

    Furthermore: As Ron van de Ven had written, XBMC freezes after the installation of your plugin, when being closed. Possibly it takes a long time until it’s finally closed but I always don’t want to wait that long and so have to “kill” it everytime.

    Best regards,

    Nick

    Reply
  4. Nick

    Hi meethue,

    unfortunately you didn’t publish my first reply so I’m writing again.
    In the meantime I had time to test your scripts and have the following results:

    Hue plugin for theatre mode only didn’t work for me in XBMC 12.2 on Windows 8 32-Bit and WIndows 7 64-Bit
    The ambilight version did only work in XBMC 12.2 on WIndows 64-Bit but not on my two Windows 8 32-Bit systems.

    XBMC shows a script error for the ambilight plugin when trying to detect the bridge automatically. On Windows 7 the script works fine. And XBMC can be shut down quickly and without freezes. This happen in WIndows 8 only. On one of my machine XBMC freezes when being closed on the other it just shuts down with a delay.

    Concerning the theatre mode only plugin: this neither works in Windows 7 nore in Windows 8 – at least for me.

    But nevertheless: thanks for this. The plugin in combination with the Hue bulbs makes more fun watching movies.

    Best regards,

    Nick

    Reply
    1. meethue Post author

      Hi Nick,

      I’ve been way behind keeping the blog updated… Thanks for you feedback! I’m developing the add-on on XBMC 12.0. Regarding the “freezes”: I know it happens sometimes, but I don’t plan on fixing it (mainly because I use XBMC on a Raspberry Pi that is always on ;-))

      I’m not sure what the issue is with version 12.2. If you get a script error, could you check the XBMC.log file and post the error message? That would help a great deal debugging the issue.

      Cheers,

      Reply
  5. Jim

    Hi!

    I; m using the latest version with frodo and aeon nox. I’m only using the dim effect and think it’s really boosting the cinema experience! I have one question though, after some time (I didn’t timed it yet) one of the lights (group of 4) resets itself. This is a random light. So it pops on to full white. I have to pause and unpause the movie and all lights are dimmed again. Then, about every ten minutes it repeats. What could this be?

    With kind regards,

    Jim

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s